FORUMS

Top-Beitragende letzte Woche
1
Gamsi Points: 6,181 Lv 30
2
OhAnnie Points: 5,041 Lv 30
3
NihilisticJedi Points: 4,735 Lv 30
4
SaigonSector Points: 4,529 Lv 30
5
wildejacht Points: 4,501 Lv 30
6
Zverinaa Points: 2,038 Lv 20
7
Wiemann Points: 2,037 Lv 20
8
Nebuchadnezzar... Points: 2,010 Lv 30
9
Aido68 Points: 1,568 Lv 17
10
mewaw_new Points: 1,000 Lv 20

Driver & Graphics Help

  • 3

I really need help figuring this out:

Kindly follow the steps below then check the playback condition of your PowerDVD 19 software:
 

1. Install the latest update for your Intel(R) UHD Graphics 630. The current driver should be version 26.20.100.7584. (Based on your dxdiag your current version is 26.20.0100.7262)

https://downloadcenter.intel.com/product/126790/Intel-UHD-Graphics-630 

2. Ensure the Intel Software Guard Extensions (Intel SGX) feature is enabled on your motherboard* in advance, and then launch Windows Update to check and install all the suggested system and driver updates.

* To perform this function on your motherboard in the motherboard firmware (BIOS), you should refer to the user manual of your PC or consult your PC manufacturer.

3. Install all Windows update To launch Windows Update, please do this:
3.1 Click the Windows button to open the start menu, and then click the Settings button to enter Windows settings.
3.2 Select Update & Security, and then click Check for Updates to check all the available updates for your PC. 
3.3 After checking, install all the suggested updates that are offered by Windows Update.

4. Ensure the Intel Management Engine driver of your PC/mainboard is the latest version provided by your PC vendor. You can update the driver from your PC/mainboard manufacturer's website.

5. Ensure the motherboard firmware (BIOS) of your PC/mainboard is the latest version provided by your PC vendor. You can update the BIOS from your PC/mainboard manufacturer's website.

6. Set your BIOS to use Intel as the main GPU.

7. Temporarily disable your NVIDIA Graphics cards. (Go to Device Manager, look for display. Right-click and disable NVIDIA. 
7.1 Reboot computer then check device manager if NVDIA is still disabled. 

8. Check the playback condition of PowerDVD 19.

If still the same concern, kindly provide us the following information:

1. Updated dxdiag showing that new update for Intel GPU is installed
2. May we clarify if it works after setting Intel to be the main GPU and disabling NVIDIA?

3. Updated Ultra HD advisor after disabling NVIDIA:

3.1. Go to this link: https://www.cyberlink.com/prog/bd-support/diagnosis.do  
3.2. Enter your Name, Email, Country
3.3. Click on Submit & Download Now
3.4. When the download is done, install the software.
3.5. Run the software, select your Blu-ray type.
3.6. The software will run a test and show the result. Click on Save log, and send the file to us.

I got the most current driver for my Intel UHD Graphics 630. It took some time to figure out though. All my other drivers are supposedly up-to-date as well. I tried going through my BIOS and I can't find anything referencing to choosing a "Main GPU". I disabled my NVIDIA Graphics Driver in my Device Manager and my problem still persists. I've gone back and forth between Dell and CyberLink support. While CyberLink has been very communicative; Dell Support basically just gave up and hasn't bothered replying back at all. Please, can anyone help me figure this out? I've been at this for weeks now and haven't had any luck whatsoever.

Antworten • 4

So what's the issue you are having? Is it laggy? Is it stuttering? 

What machine do you have? 

What Processor, Ram, and GPU? 

Also, maybe try a different software, if powerdvd can't use a dedicated graphics card, it's a garbage program. You should NEVER have to disable your dedi card to use onboard video, NEVER. 


GelidPhoenix said:

So what's the issue you are having? Is it laggy? Is it stuttering? 

What machine do you have? 

What Processor, Ram, and GPU? 

Also, maybe try a different software, if powerdvd can't use a dedicated graphics card, it's a garbage program. You should NEVER have to disable your dedi card to use onboard video, NEVER. 

Alienware M15 R2:

260+ FPS, VR Ready

9th Gen Intel Core i9-9980HK (8-Core, 16MB Cache, up to 5.0Ghz w/Turbo Boost)

NVIDIA GeForce RTX 2080 8GB GDDR6 w/ Max-Q Design

16GB, 2x8GB, DDR4 2666MHz 4TB (2x2TB PCIe M.2 SSD) RAID 0

15.6" OLED UHD (3840x2160) 60Hz, 1ms, 400-nits, DCI-P3, Eyesafe Display Tech + Tobii Eyetracking

Killer Wi-Fi 6 AX1650 (2x2) and Bluetooth 5.0

240W Power Adapter

 

It took some time, but I was able to update my Driver from 7262 to 7755. The External Disc Driver and program runs with a standard DVD and Blu-Ray discs, but when I put in a 4K Disc, that's when I get an error message with PowerDVD. And every time; after a few seconds after the error message, my entire PC locks up, forcing me to hard-boot.

I've been considering reformatting my laptop to see if that might help, because I'm not sure if I'm getting the full 4K/UHD experience from my laptop. I know in the Display Settings, there's an option to toggle the HDR Setting, but all it appears to do is give it a filter of sorts. When I play games that are capable of HDR/4K/UHD (whatever you wanna call it), the 4K settings are completely grayed out in the game's settings. For example, Assassin's Creed Origins and Odyssey.

EDIT: Just updated to 7870 now.

edited

Try VNC for Video?

Or you reinstall Nvidia and select "New Installation". That works in my Case.

After u changed so much, u better Reset BIOS Settings and if u have the Time, clean OS with keeping Files.

edited

Howdy Nahr_Alma,

Based on what I read from the Cyberlink website, you can only play UHD media on the internal Intel GPU, which is why they keep talking about your Intel driver.  However, depedning on your hardware configuration, you may not be able to access the Intel GPU in your system.  Does your system use nVidia GSync?  If that is the case, you will not be able to use the Intel UHD video on the internal display, as it is not physcially connected.  If your system supports nVidia Optimus (which is not compatiable with GSync), then you just have to force the Cyberlink program to use the integrated GPU.  You should be able to do this by right-clicking on the desktop shortcut, and using the nVidia submenu to force a specific GPU.  A few Google searches reveal conflicting information on if your laptop supports Optimus or not.  The actual nVidia website does not list your GPU as compatiable with Optimus, but here on the Dell site they mention it: 

https://www.dell.com/support/article/us/en/04/sln146534/configuring-nvidia-optimus-and-amd-switchable-graphics-for-high-performance-on-your-alienware-system?lang=en

Give these instructions a try :-)

Good Luck!

Rich S.